[ ubuntu ] enable bluetooth using command line

Problem

$ hcitool scan
Device is not available: No such device

Try

$ hciconfig dev
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 00:21:86:4A:84:81  ACL MTU: 310:10  SCO MTU: 64:8
	DOWN 
	RX bytes:466 acl:0 sco:0 events:18 errors:0
	TX bytes:73 acl:0 sco:0 commands:17 errors:0

Solution

$ sudo hciconfig hci0 reset

Check

$ hcitool scan
Scanning ...

Now it works !
ref : https://bbs.archlinux.org/viewtopic.php?id=126603

[ windows ] terminate remoteApp session + terminate remoteApp session within remote desktop/windows xp mode

Terminate remoteApp session

Instead of using Ctrl+Alt+Del to kill the local process,

Ctrl+Alt+End is used to kill the remoteApp process.

Terminate remoteApp session within `remote desktop` or `windows xp mode`

scenario_kill_remoteapp_session

If we use remoteApp inside the remote desktop, Ctrl+Alt+End will open the Remote Desktop task manager ( not the remoteApp that is inside the remote desktop ).

The solution is to use the On-Screen keyboard ( start > All Programs > Accessories > Accessibilities > On-Screen keyboard ) inside the remote desktop session.

The tips is that, we have to choose the program window before we press `Ctrl+Alt+End` on the `On-Screen Keyboard`.

ctrl+alt+end+win+xp+within+remote+desktop

Another ( not quite good ) solution is set the session timeout in gpedit.msc

Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remove Desktop Session Host\Session Time Limits

windows_server_set_session_timeout1

set from `Not configured` to `Enable`

and `1 minute`

windows_server_set_session_timeout2

[ ubuntu ] checking SD card bad blocks ??

เมื่อวาน เอา Samsung Galaxy Note 1 มาชาร์จกับ คอม ที่ลง Windows Vista

เปิดมาวันนี้ SD Card แม่ม mount ไม่ได้

เข้าไป setting > storage > mount ก็ไม่ได้

มันบอกว่า Preparing หลังจากนั้น มันบอกว่า SD card safe to remove #พร่องส์

แต่มันติดอยู่ที่ว่า reboot โทรศัพท์หลายๆ รอบ มันขึ้นให้ format USB storage

บอกว่า blank USB storage or file system type is not correct อะไรเทือกๆนี้

พยายามหาทางแก้โน่นนี่นั่น ก็ไม่หาย

ลองเอา SD card ใบอื่นไปเสียบใส่โทรศัพท์แทน ก็ไม่สามารถ mount ได้ และขึ้นให้ format USB storage เหมือนเดิม

ลองเอา SD card กลับมาเสียบกับคอมพิวเตอร์ เพื่อเอาโปรแกรม recovery รูปกลับมา ก็ดันได้รูปเมื่อปีมะโว้

ทำไมรูปที่เพิ่งถ่ายหายไปอย่างไร้ร่องรอย ขนาดโปรแกรมกู้รูป ยังกู้กลับมาไม่ได้ #มนุษย์ต่างดาวขโมยไปหรืออย่างไร

สงสัยคงเป็นชะตากรรมให้ต้องทำอะไรบางอย่างซ้ำอีกครั้งหนึ่ง

แต่ก็ยังตะหงิดๆ ว่า มันยังไงกันแน่หว่า

เป็นเพราะ SD card ห่วย Samsung ห่วย หรือว่า Android ห่วยกันแน่

สาเหตุยังไม่แน่ชัด

แต่ตอนนี้ลองกด format USB device ไปก่อน ด้วยทำใจว่า รูปหายหมดแน่ๆ

แต่หลังจาก format แล้ว มันก็ mount SD card ได้ปกติ

เวงกรำจริงๆ

คิดว่า SD card ไม่น่าจะใช่สาเหตุ เพราะลองกับ SD card ใบใหม่ แล้วได้ผล เอ๋อเหรอ เหมือนกัน

แต่ก็ยังลองเช็ค bad blocks ดูก่อน

ข้างล่างเป็นวิธีจ๊ะ

1) ก่อนอื่นดูก่อนว่า /media/xxx นี้ อยู่ที่ /dev/yyy ไหน ใช้คำสั่ง ตามนี้

$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sdc      8:32   1  14.9G  0 disk 
└─sdc1   8:33   1  14.9G  0 part /media/3535-6231

2) หลังจากนั้น ก็ badblocks โลด

$ sudo badblocks -v /dev/sdc1
Checking blocks 0 to 15554047
Checking for bad blocks (read-only test):   0.00% done, 0:00 elapsed. (0/0/0 errdone                                                 
Pass completed, 0 bad blocks found. (0/0/0 errors)

ปล

ในเวป เขาแนะนำมาอย่างนี้ ก็ลองตามเขาอะนะ

ไม่แน่ใจว่า จานหมุน กับ วงจร มันจะเช็คได้เหมือนกันหรือเปล่า

เช็คไปก็ไม่เจอ badblocks เลยลองใส่กลับเข้าไปก่อน

– หลังๆ หุ่นกระป๋อง เอ๋อ บ่อย ขนาด reset วันที่กลับไปเป็นวันเริ่มต้น

แต่ถ้าปัญหานี้มาบ่อยๆ คงไม่ไหวเหมือนกัน

ไม่รู้ว่าเกิดจาก ที่เราเอา มือถือ มาชาร์จกับ คอม หรือเปล่า

เห็นว่า มี mount `mass storage`, หรือ `MTP`, หรือ `PTP` บ้าบอๆ

ปกติไม่ได้ชาร์จ คราวนี้เอามาชาร์จ เลยเป็น

– แม่มอุตส่าห์ ถ่อไปพันทิพย์ เพื่อซื้อ card reader สำหรับ micro SD มา ( 40 บาท )

เพราะว่า card reader ตัวเก่า เป็นของโบร่ำโบราณ ไม่มี port micro SD