[ rails c ] in `block in setup’: You have already activated spring 2.0.1, but your Gemfile requires spring 1.3.4. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)

Problem

in `block in setup': You have already activated spring 2.0.1, but your Gemfile requires spring 1.3.4. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)

Solution

way1 ( recommended ) *** : remove the updated one

$ gem uninstall spring

Select gem to uninstall:
1. spring-1.3.4
2. spring-2.0.2
3. All versions
> 2

or way2: update the spring 

bundle update spring

ref : http://stackoverflow.com/questions/34628944/already-activated-spring-1-4-0-but-gemfile-requires-spring-1-3-3error

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s